- Retrieving photo data from Flickr API
- Quantitative processing in MS Access
- Spatial clustering in ArcGIS
- Mapping and Symbolization




Software:
MS Access 2003, 2007, 2010, 2013
or MS Access Runtime Sfree)

(See Software/AccessRuntime_x64_de-de.exe (64bit), AccessRuntime_x86_de-de.exe (32 bit))
Access Photo data processing form: <..\02STEP\importdata.accdb >

ESRI ArcGis 10.1+, ArcInfo License

(Standard License may work, but slow due to using Buffer instead of Aggregate)

Flickr ArcGis Toolbox . \03STEP\01_TOOLS\PhotoGeotagTools.tbx >

Recommended: Copy “01_TOOLS” Folder to <C:/01_TOOLS/ >

PhotoData Toolkit -.\istercetceo.exe » (Windows 2007/2008 x64/x86 only)

(in case program does not run, install using <...\O1STEP\Setup_Files\setup.exe >

Optionally:
LibreOffice Portable for editing *.dbf-Files

(See <Software/LibreOfficePortable/LibreOfficeCalcPortable.exe >)

Preparations




Load data and choose clipping extent
 Sudbu alexanderdunkel.com -

| LosdFor ...\Input\
s
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7927734375 Toze o Era
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e =

' 1
rently in test mode.

nctions for more information.

- For clipping data from existing dataset

- OPEN <..\O1STEP\GETGEO.EXE >

- Open ClipData Tool (1)

- Load Folder <..\Input\> (2)

- areas with existing datasets are highlighted by red boundary
- Choose clipping extent by moving markers (3)

- Optionally use temporal constraints for photodata (4)

- Search will preview available photo data for criteria (5)

- Export will save photo data to < ...\Output\NAME\ > (5)
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- For retrieving new data from Flickr API
Open GetGeo Tool (1
- Choose timespan for photo data (2
- Choose spatial extent for photo data (3
- Click ,,Show Map"
- zoom/pan to area
- click on LAT / LONG to update POSItlon
- Optionally, limit search to specific tags,
separated by comma (3a
- Enter Name and click Export (4
-  Export will save photo data to < ..\Output\NAME\ >




- Output folder < ...\Output\NAME\ >

contains datafiles + additional files

- Photos itself are not downloaded

- Datafiles contain comma separated photo data,
including URL to photo

- Select all datafiles..

ssing b O1STEP » Output » WLO1

- Share with Print Burn

|| GridCoordinates.tdt
|| logbd
|| settings.bet | WLD1_Part1_844 Tilel.txt - Notepad

| WLO01_Partl 844 Tilel.bt | File Edit Format View Help

ID,LatitudE,Longﬁtude,NﬁME,URL,PhotoID,Owner,UserID,DateTaken,UEToadDate,Views,TaQS,MTags
1,43.540771,-80.553646,5t. Jacobs mill,https://farm8.staticflickr.com/7504,/15844733307_&ab
2,43.539394,-80. 553796, ,N1ght-Time 5t. Jacobs snowy Photowalk 9,https://farmg.staticflickr.
3,43.539635,-80. 55386,Night-Time . Jacobs sSnowy Photowalk 10,https://farm§.staticflickr.
4,43,539635,-80, 55386, ,Night-Time . Jacobs snowy Photowalk 3,https://farm9.staticflickr.c
5,43.539122,-80. 55386,Night-Time . Jacobs snowy Photowalk 5,https://farmé6.staticflickr.c
6,43.54032,—80.553249,Njght—ije . Jacobs sSnowy Photowalk l,https:fffarmg.statjcf1jckr.c

—Ei) a0, N OO — [l o Nowy FOoTowa | kK4, (] H arms

Review Data




..and copy to folder
< 02STEP\INPUT\ > . e
E— A importdata.accdb

Go to Folder
< ..\O2STEP\>

Copy
importdata.accdb

Rename & open
new Access
Database

Prepare Access database




Enter name for Geotag Database Tools
Import table (1) 1. Fileimport

Folder: \Input\

-« Click mporname: mporspecticain:
a) Load *.txt L r ST
b) Add Primary b)

Remove any el
duplicate data

entries (2):

2. Processing A: Duplicates

MName Original: wWL01_UID Column: PhotolD

| Remove Duplicates J Cu:rpu_es tablfe and removes
4| duplicates in specified column.




Export table to *.mdb
(ArcGIS 10.0 compatible database)

...data is exported to

< ...02STEP\OUTPUT\*.mdb >

We will later use this file for mapping
photo location data in ArcGIS

WLO1_UID

\Output\

Exports data fr
x
Export *.MDB MDB compatible with ArcGis 10




1/1 Done.
b)
Mame: WLO1_UID_DistCl

3. Processing B: Tags
Template: Taglist_templ

Table:

a)

WL01_UID_Dist
Sort Out Global: SortOutAlways

Clean Tag Data
Sort Out InStr *:|SortQutAlways_InStr

0/0 _
/ Output: Taglist_WL01_UID_DistCl

| Separate Tags l

- Analyze available tags in dataset

- Clean Tag Data first (1

(each tag is counted once per user

- Remove tags based on stop list (2
(optionally edit stop list first >
Tables: SortOutAlways and SortOutAlways_InStr)




- Count distinct tags (1)

- ...duplicate list (2)..

- Select tags for clustering in ArcGIS ...

- ..by first removing unwanted tags (3)

. humber of total tags influences cluster processing time,
recommended: first 1000 or less)

‘53] Database Tools.\"[ﬁ Taglist WLO1_UID_DistCl_Count
TAGNAME - TAGCOUNT -
stjacobs 47

42

Taglist_WLO1_UID_DistCl | canada 35

| Jacobs 11

waterloo 11

ontaric

|Tags

Taglist_WLO1_UID_DistCl |

=t
=

a) [ Count distinct Tags lh] [ Duplicate J

|Tag|ist_..._Cc~u nt

\Output\ | ' orange

[ Export *.XLS Exports data from specified table to tree

Excel Spreadsheet.

trees
bridge

[ Export *.XL5X Exports data from specified tahle to Excel 2007
Spreadsheet (allows more than 65,536 rows).

[ Export *.DBF Exports data from sp-ecified_table to sNow
* dbf table (Supported only in winter
Access 2010 and below).

(e B = L T o I IR R Y I W




- Export table to

*.dbf File (only works in Access 2010 and earlier)
or *.xls File (Excel)

- Saved to < ...02STEP\OUTPUT\*.xlIs >

Taglist WLO1_UID_DistCl

Tags

ing » 0D2STEP » OUTPUT - | 4|

Taglist_WL01_UID_DistCl_

Count distinct Tags J b) Duplicate | _ i Share with = Print =  FZ

Taglist_WL01_UID_| Dlst( Export_WLﬂl_UID.mdb
| || Taglist_ WLOL_UID_DistCl_Count_Sel.xls |

\WOutputh

Exports data from specified table to

Export *.¥LS
po Excel Spreadsheet.

Exports data from specified table to Excel 2007

Export *.XLSX
Spreadsheet (allows more than 65,536 rows).

Exports data from specified table to
"4 # dbf table (Supported only in
Access 2010 and below).

Export *.DBF




I8 Warks... » 04_Processing »

A Share with « Print

| D1STEP
. D25TEP
| D35TEP
. GIS_DATA
| Software
| Basemaplayout.mxd

=]

[-l- Copy to 04_Processing

; eanERBR @S - BBRS

- make a copy of BasemapLayout.mxd

- Rename & open file in ArcGIS

- Repair missing data links if necessary
Set paper layout to A1 Oversize or similar
(24.61 x 35.43 Inches)

- Display example photo data:

Enable Layer AllIPhotos_TorontoRegion




SEMmap ut_| . - Arcivlap

Add XY Data
File | Edit View Bookmarks Insert Selection Geoprocessing  Custornize  Windows  Help
A table containing X and ¥ coordinate data can be added to the : .
map as a layer |__D| Mew... Ctrl+M b - | 1:397.704 - [;] %
Choose a table from the map or browse for another table: Ei‘ Open.. cul-0 IE‘ 0 1:.1:1 H :ﬁ 13' N
[ wiotup - @ & save Ctrl+S g x
- . Save As... aoo
Specify the fields for the X, ¥ and Z coordinates: X
Save A Co Labeling - ’% i Q !{‘3 éh &
¥ Field: Longitude - Y. -
il {[=

¥ Field: Latitude - Share As ’ | | E

Z Field: <None> - Ei b | & Add Data..

Coordinate System of Input Coordinates

Description: .

d Print Set +:
Geographic Coordinate System: - Pageland Prin L. | %v AddXYData...
Name: GCS_WGS_1934 3 -

I

S _ : - Choose File > Add Data > Add XY Data
e LEe ~ Load < ..02STEP\OUTPUT\*.mdb >
[7] Warn me if the resulting layer will have restricted functionality ) X Flel d — Longl tu de
E— o« ) [caed ] - Y Field = Latitude

- Coordinate System of Input:
GCS WGS 1984

(Edit > Geographic Coordinate Systems > World > WGS51984)
- Click OK to import data

- Right-Click > Zoom to Layer

- Project Features to WGS_1984_UTM_Zone_17N (Canada)...
- (Menu Geoprocessing > Search For Tools > Project Tool)
Save to < C:\01_TOOLS\O1_Input\PhotoLocationData.shp >




Selection Geoprocessing  Customize Wi

Ctrl+M r_,-. - (=h0-054 : ' = Zran

L =

Ctrl+ O Joins and Relates

@
k Lutatard il Ch\Users\ADYstud Remove Open
Ctrl+5S | [0 Administratio Open this table. Shortcut: CTRL +
| ] = ne_S0m_p Data double-click table name OR CTRL

Save As.., L Edit Features ~T

= ne_S0m_u
O

= | Tt

Share As B B neS0m_a¢ ',

Geocode Addresses..,

Save A Copy...

7 Display Route Events...
Display XY Data...

Add Data ”(ﬂo Properties...

Table
Bl =R

n Find and Replace..

B Select By Attributes...

& 5 - For Access 2013, convert *.xls to *.dbf:

[ Select All 11

4 - Choose File > Add Data > Add Data...
Load Table from < ...02STEP\OUTPUT\*.xIs >
- Right-Click Table > Open
- Choose Menu > Export
-  Export table as DBase Table to
< C:\01_TOOLS\01_Input\Taglist.dbf >

Turn All Fields On
Show Field Aliases

Arrange Tables 3

Restore Default Column Widths
Restore Default Field Order

Joins and Relates 3
Related Tables 3
Create Graph...

Add Table to Layout

Reload Cache

B

gk T

Print...

Reports »
Export... I

Appearance.
reflections
horse Exports the table to a new table.
silos
town

Export

o | | [ | [en | en [ en en [en [en | en|en e [en [en | onen |on fon @ | @ | | (@ |~ |~ |~ oo
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ArcToolbox
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ED‘J TagRunnerV1.1 =Bl
= & PhotoGeotagTools n
b Calculate Weights Input Ranbats : —
. C:\01_TOOLS\01_Input\PhotolocationData.shp
e Cluster Photo Locations o
mpTag
&Pa Merge Output €:101_TOOLS'D2_Cutputiputput_%TagNameValue %.shp
§>ﬂ Model Taglist.dbf
C:\01_TOOLS'\01_InputiTaglist.dbf E;-
4 Splder Aggregation Distance .
ba TagRunnerV1.0 EEE— 500 | [Meters -
§:N:| TagRunner‘u‘l.l_anal [ OK J [ Cancel ] [En\tironments... ] [ Show Help > ]
- - - -
@ @ .




Input RawData:

.. Single photo locations and tags

HImpTag:

.. Output cluster files for each tag in Taglist.dbf

Aggregation Distance:

.. Accuracy of processing: choose value based on
scale of analysis & final display size

%ba TagRunnerV1.1

Input RawData
C:\01_TOOLS\01_Input\PhotolocationData. shp

HImpTag
C:\01_TOOLS\02_Outputioutput_%eTagMameValue %o, shp

Taglist.dbf
C:\01_TOOLS\D1_InputiTaglist.dbf

Aggregation Distance

10000

ESEEEE )

[Meters

[

K _] rl Cancel ] [Enuirnnments... ] [ Show Help == ]

Generate Tac




- Output Files are saved to..
< C:\01_TOOLS\02_Output\ >
- Select all output files and Merge to a single file using Merge
_ (Data management Tools
(Menu Geoprocessing > Search For Tools > Merge Tool ]

- Or: Use Tool PhotoGeotag Tools > “"Merge Output

‘E‘h Merge

!-—-LE@Q

Conterts | Preview | Description |

Mame

output_abandoned.shp
output_abandenedhouse.shp
output_abigfave.shp
output_abstract.shp
output_accident.shp
output_action.shp
output_acton.shp
output_ad.shp
output_adventure.shp
output_advertising.shp
output_african.shp
output_africanlionsafari.shp

Input Datasets

C:\01_TOOLS\02_Outputhputput_afternoon.shp
C:\01_TOOL5Y02_Outputiputput_abandoned. shp
C:\01_TOOLsY 2_Outputioutput_abandonedhouse.shp
C:\01_TOOLsY 2_Outputioutput_abigfave.shp
C:\01_TOOLsY 2_Outputioutput_abstract.shp
C:\01_TOOLsY 2_Outputioutput_acddent.shp
C:\01_TOOLS\02_Outputioutput_action. shp
C:\01_TOOoLs\02_Outputiputput_acton.shp

4|_1 ]

QOutput Dataset

C:\01_TOOLSYTagClusterMergeAll. shp

CIEANEIEINA

6.

-

m

-

| ok

output_after.shp

” Cancel

] [Enuironments... ] [ Show Help == ]

output_aftermath.shp
output_afterncon.shp




TagClusterMergeAll

Shape * Join_Count ARGET FID | Views | FREQUENC COUNT User UM FREQUE | ImpTag | TagCountG | HimpT.

+ 0§ Polvgon 4 0 24 1 1 4 | afternoon 1136 ]
1 | Pohygon 3 1 540 2 3 | afternoon 1136 ]
2 | Polygon 3 2 1547 r ‘ = IS —r = =
3 | Polygon 1 n & 530 Calculate Weights =
4 | Polygon 1 1] 427
& | Polygon 1 ] 11 i
& | Polygon 1 0] 248 eI
7 | Polygon 1 1] 210 C:\01_TOOLSYTagClusterMergeall. shp
& | Polvgon 1 0 o)

9 | Polygon 1 0| =38 I
10 | Pokygaon 1 0 12 C:\01_TOOLSYTagClusterMergeall_Weights.shp
11 | Polygon ! J = Weights Farmula

- Merged results file contains a list of all Tag Clusters:
[Join_Count] > Number of Photos in each Cluster
[Views] > Sum of Views for Photos in each Cluster

L. 1+ [Join_Count] *(sgr{1/( [Join_Count] / [COUNT User] 1~3))

QK Cancel Environments. .. 5 Help ==

[COUNT_User] > Number of Photographers
[ImpTag] > Tag Cluster Name

- Weights are used to calculate Font Size

- To Calculate Weights, ...

use Tool PhotoGeotag Tools > "Calculate Weights”




Extent
Top: 4994509,635500 m

Left: 475908.509400 m Right: 752370.415900 m

Bottom: 4692320.337900 m

Data Source

Shapefile Feature Class -
PhotoTags_Mergeall_Weights

E:'Promotion_2014-04-14'01_Daten‘\Arcgis\CanadaiTo
Simple
Polyaon

(=Y GTA_AllTagsMergeSk_SortedWeightTags, @ copy

= [ GTA_AllTagsMergeSk_SortedWeightTags X Remove

-

| P

= [0 GTA_AlTagsMergeSk_SortedWeightTags lains and

» | setData Source...

- Open your copy of BasemapLayout.mxd

- Use existing symbolization for Tags-Layers:
Right Click First Layer > Properties > Data Source
- Click Set Data Source and Choose

Merged Results File from previous step

- Repeat process for next two tag layers




AllTags1000_Merge Weights

FID | Shape* | Join Count | TARGET FID | Views | FREQUENCY | COUNT User | SUM FREQUE | ImpT. HimpTag J| Weights
2872 | Pohvgon 4539 01 1126 235 235 4539 | waterloo 1 §54.471418
1445 | Pahrgon 378 0| 571855 158 158 3578 | kitchener 1 §34.202083
3359 | Polygon 609 0| &87sa6 77 T7 5059 | cambridge 1 B28.375622
2307 | Polygon 145 1 18763 37 37 149 | river 1 .

1114 | Pohsgon 93 0| 23508 30 30 93 | grandriver 1 [f18.038855

. - 1 22 40 | church 1 [f17.315637

Layer Properties - - 28 23 [ train 1| 17.2629
42 345 | park 1 [§15.570056

| General | Source |Seleciiun | Display I Symbulugyl Fields | Definition Guery E &3 149 | galt 1 15.14
16 21 | bridge 1 [f14.9655845

Definition Query: 18 32 | water 1 14.5

"Weights™ == 20 AND "HImpTag™ = 1

- Tags are placed on the map in the following sequence:

First, most used tags (largest font size) are placed in background
Layer 3: Weights > x AND [HImP] =1

Second, each cluster with the most occurrences for each tag is placed:
Layer 1: Weights < x AND [HImP] =1

Finally, all other tags are placed:

Layer 2:[HImP] =0

- Edit Definition Query (Layer Preferences) to select the number of tags
which should get placed in background:

Example:

Definition Query "Weights" >= 20, all labels with weights over 20 are
placed in background.




s rrmen e

[ Append ] [ Show Values... ] Display coded value description

Expression

[ Loyer Propertis == Write the expression in the language of the selected parser. [ Advanced

| General | Source | Selection | Dispiay | Symbology | Fislds | Defintion Guery | Labels | Joins & Relates | Tme | HTML Popup

this layer

d P name ="Arial' size=" % EEERINEEIES & =" & [ImpTag] & "</FNT> =

[ Bpeson._}

@) Al -2 -
[ BRI
Other Opti Pre-defined Label Style

fors
Placement Propeties.. | | Sosls Rengs Label Styles. 4 |

| veify | [ Reset ||

Parser: ['u'BScript

- The Font Size Modifier is used to adjust Fonts to your final map
display size (Paper Size)

-  For each tag layer, go to ...

Layer Properties > Labels > Expression

- Adjust Modifier: 7+sqgr([Weights])*5

7 = Set minimum Font Size
- Sqr = optional flattening of font size display curve
5 = Set largest Font Size




Labellng iR a5 Q w|| Fast

View Unplaced Labels

Draw the labels that could not be
placed. The unplaced label color
can be changed on the Labeling

Options dialog.

- final map display depends on several criteria:

- Use different Aggregation Distance [AD] if information resolution is too
uzzy, or too man?/ duplicate clusters exist (AD too small)

- Use different weighting formula, examples:

1+ [Join_Count] *(sqr(1/( [Join_Count] / [COUNT_User] )~3)) - Standard weighting formula

1+ [Join_Count] *(sqr(1/( [Join_Count] / [COUNT_User] )~2)) - less importance on User_Count in correlation to

hoto count [IJom Count]
sqr(([Join_Count]+(2*sqgr([Join_Count])))*2) - Ignores User_Count, this will emphasize

individual and very active users

- Use Right-Click > Labeling > “"View Unplaced Labels” tlo verify tag
acement,

..red labels are labels not placed on the map due to label density issues

- Adjust Font Size Modifier if Fonts are too large or small,

or placed too far off
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